first ever crash of armagetronad with strange output

For all the help you need with Armagetron!
Post Reply
fungilife
Posts: 2
Joined: Wed Sep 15, 2021 6:56 pm

first ever crash of armagetronad with strange output

Post by fungilife »

This is on Arch (all current) armagetronad 0.2.9.1.0 have been using it for a while, I've never ever seen it crash. This is a sudden first

Code: Select all

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0x2000012
  Serial number of failed request:  355
  Current serial number in output stream:  357
Windows left AI team.
Unreal left AI team.
Quake left AI team.
Linux left AI team.
MSVC++ left AI team.
Pine left AI team.
Elm left AI team.
Vi left AI team.
Emacs left AI team.
Photoshop left AI team.
Gimp left AI team.
terminate called after throwing an instance of 'tGenericException'
/usr/bin/armagetronad: line 2:  9895 Aborted                 /usr/bin/armagetronad_bin --configdir /etc/armagetronad --datadir /usr/share/armagetronad
Good thing I start it on terminal so I get to see this, if it was on a menu item I doubt I'd find a trace.
User avatar
Z-Man
God & Project Admin
Posts: 11461
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Re: first ever crash of armagetronad with strange output

Post by Z-Man »

Sorry for the late approval and reply... were you trying to switch to/from fullscreen mode at that time? XF86VidModeSwitchToMode should not be called just out of the blue.
Just asking out of curiosity. 0.2.9 is still using SDL 1.2 to talk to the system and that is by now unsupported by the developers, so unfixable compatibility problems are bound to crop up.
Post Reply