0.2.8.3_beta2 available!

Help test release candidates for the next release
User avatar
Z-Man
God & Project Admin
Posts: 11220
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

0.2.8.3_beta2 available!

Post by Z-Man » Fri Feb 27, 2009 7:05 pm

Get it in the usual places:
- SourceForge
- aabeta
- Launchpad

Apart from lots of bugfixes, changes were:

Code: Select all

- Prepared for Armatrators
- Authentication routines now use utf8 as forward- compatibility with
  trunk. Previously, non-ASCII usernames simply didn't work at all.
- Better lag slide protection: clients no longer get confused when
  the server sends their cycle back in time, and the server no longer
  does that for old clients.
- Fixed rare wallpassing bug; it required what whould usually be an
  instakill and infinte wall length.


The authentication stuff is important for authority owners. It means that to get non-ASCII passwords and usernames to work, you need to adapt your authority to work with uft8 internally. Especially, all hashing has to be done on uft8 strings, and usernames passed in as utf8.

We still have, at the time of this writing, two incomplete bugs, ghost walls and invulnerability. We think both are fixed, but can't be sure, because from neither, we have a relevant recording. If you could try to reproduce the invulnerability bug on the Bugfarm servers, that would be great. Or, alternatively, send in a serverside recording of it happening on any server version. Or try and fail to reproduce it on Bugfarm and report that :)

Anyway, happy testing.
Last edited by Z-Man on Sat Apr 04, 2009 9:40 am, edited 1 time in total.

XzL.Smart
Round Winner
Posts: 216
Joined: Sun Apr 30, 2006 4:21 am
Location: Arizona

Post by XzL.Smart » Fri Feb 27, 2009 8:35 pm

Does it still have that crappy looking text?

Edit: I answered my own question by downloading it.

Can I get the mini map in this version. I needs it!

And I hate the little meters at the bottom. How do I change them?

User avatar
Z-Man
God & Project Admin
Posts: 11220
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected].de
Contact:

Post by Z-Man » Fri Feb 27, 2009 8:51 pm

If you want truetype fonts, you'll need to use 0.3.0, 0.3.1_beta1 or a trunk build. The same goes for the new HUD, music, map rotation, chat tab completion, fancy new zones and whatnot.

If you're missing the release process, there was none :) For betas, I think the branch is in enough shape to just tag, build and release. The release candidates will have a round of "right, anything missing before we release?" again.

User avatar
DDMJ
Reverse Outside Corner Grinder
Posts: 1881
Joined: Thu Jun 08, 2006 12:15 am
Location: LA, CA, USA, NA
Contact:

Post by DDMJ » Sat Feb 28, 2009 7:29 pm

I think I know about the "Cycles turning invulnerable" bug.

Assuming it's the one I'm thinking of, this is what appears to happen:

Out of now where, a player's cycle will appear to stop moving completely on everyone else's screen. Players can then drive thru his walls and won't die.

Now, the player that's cycle is "stuck" can still move on his screen, but he can't die or do anything else (capture a zone).

Is this the bug that you're talking about?

User avatar
Z-Man
God & Project Admin
Posts: 11220
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Post by Z-Man » Sat Feb 28, 2009 7:46 pm

That was one of the manifestations that was reported, yes. It's what happens on the single clientside recording we have of it. I don't know whether there are others, I seem to recall another variant where the cycle could still move on everyone's screen and simply could no longer die, but evidence for that is even thinner.

User avatar
Z-Man
God & Project Admin
Posts: 11220
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Post by Z-Man » Sun Mar 01, 2009 11:41 pm

Yay! We have a serverside recording of the invulnerability bug. It takes ages to play back and only plays back on the server itself where gdb isn't working properly, but it plays back. It's 50 MB compressed, so I'm not uploading it anywhere, there wouldn't be much use.

User avatar
Tank Program
Forum & Project Admin, PhD
Posts: 6698
Joined: Thu Dec 18, 2003 7:03 pm

Post by Tank Program » Wed Mar 04, 2009 11:48 am

Bit of an aside, Version Tracker already has 0.2.8.3_beta2 up. A bit surprising.
Image

User avatar
Z-Man
God & Project Admin
Posts: 11220
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Post by Z-Man » Wed Mar 04, 2009 12:03 pm

Interesting. Who updates that?

User avatar
Tank Program
Forum & Project Admin, PhD
Posts: 6698
Joined: Thu Dec 18, 2003 7:03 pm

Post by Tank Program » Wed Mar 04, 2009 2:19 pm

No clue.
Image

Paladin
Average Program
Posts: 99
Joined: Tue Feb 26, 2008 11:04 pm
Location: Ontario

Post by Paladin » Thu Mar 05, 2009 5:12 am

Hopefully this is the correct spot.

It is more than possible that this is what you were mentioning, Z-Man, about ghost walls but, if not, hopefully it helps regardless.

On the beta1 of .2.8.3, I noticed that at times my tail seemed to split in half, resulting in me producing a real tail and a fake tail on my screen.
The fake tail was created by the bike. The camera followed it.
The real tail was simply created with the absence of a bike without any camera following it.
Both reacted to keyboard commands. The fake tail was simply out of place anywhere within a couple of inches of the real one and seemed to react slower to keyboard commands.
This only occurs in internet games, not in local games, when I am on dial-up internet (24.0 kbps general speed). From talking with people, no-one else saw the tail splitting. I would have reported it prior, but I became lost in other things and simply assumed it was my internet. My reason for posting was to see if other people had had similar problems (and if so if it was fixed) or if it was simply my internet colliding with, what was, the newest release.

Thanks for Beta2, eh? Hopefully I can download it shortly.

User avatar
-=VcL.Rajinn
Round Winner
Posts: 242
Joined: Fri Aug 29, 2008 9:35 pm

Post by -=VcL.Rajinn » Thu Mar 05, 2009 7:00 am

Ok, thanks for this update Z-Man.

I have the following servers running it, mostly Higher Rubber servers.

Armagetron Classic »High Rubber«
Armagetron Classic »Hangout«
~3Ld~| EarthsLast Descendants - High Rubber

On the High Rubber servers, I noticed it's a little smoother playing. And this is an ideal server to try and capture that bug of infinite rubber. I have done it many times on High Rubber servers.

Thanks again!

User avatar
Z-Man
God & Project Admin
Posts: 11220
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Post by Z-Man » Thu Mar 05, 2009 2:24 pm

Paladin: that's just regular lag of a variant that keeps the client from properly syncing with the server state. The 'slow' walls are the true walls as the server sees them, the detached 'fast' walls are local predictions of your client that are out of sync. The desync should go away once you stop turning mainically. It's a bug, too, but not one we'll be able to fix anytime soon; I tried recently to sync more liberaly, but the result was that the cycle would often jump around on the client in ways that make it impossible to control in such situations. It does have nothing at all to do with the ghost walls :)

Rouge: sorry, I failed to give an update here: the 'invincibility' bug that was caught in the recording is fixed now. I shall put up beta3 with the fix sometime soon (<1 week).

There's new incomplete bugs now, though. There's an unknown crash reported on both client and server. Previously, we thought that the crash may only affect sty versions, but I also had in on a (sadly non-recording) vanilla server now. Any info on strange crashes (best in the form of recordings) is welcome. As far as I can tell, it's very rare, so I don't consider it a blocker.

Paladin
Average Program
Posts: 99
Joined: Tue Feb 26, 2008 11:04 pm
Location: Ontario

Post by Paladin » Thu Mar 05, 2009 4:37 pm

Much thanks for the clarifying reply Z-Man. :)

User avatar
-=VcL.Rajinn
Round Winner
Posts: 242
Joined: Fri Aug 29, 2008 9:35 pm

Post by -=VcL.Rajinn » Thu Mar 05, 2009 4:46 pm

Thanks much Z-man

User avatar
dlh
Formerly That OS X Guy
Posts: 2034
Joined: Fri Jan 02, 2004 12:05 am
Contact:

Post by dlh » Fri Mar 06, 2009 5:14 pm

Kamp had a segfault running this version on Windows. Maybe he can give more details, or reproduce it. There also was a user on IRC who reported that this version crashed.

Post Reply