Can't get fortress zones to align to the proper team.

Designed a level that creates new, exciting, and challenging Armagetron game play? Or maybe just something funky. Put it right here.
OldMcdonald
On Lightcycle Grid
Posts: 11
Joined: Wed Jun 20, 2012 2:16 am

Re: Can't get fortress zones to align to the proper team.

Post by OldMcdonald »

What I was hoping for was a map with 2 teams of 4, with one team defending and the other attacking in 4 different directions from the center. Basically this was just to help the newer or less skilled players learn some skills in a less pressure intensive setting.
But if there's no way I can get all players starting facing the correct way in their respective positions, then i'll probably have to make compromise or change the map entirely.

User avatar
Light
Reverse Outside Corner Grinder
Posts: 1664
Joined: Thu Oct 20, 2011 2:11 pm

Re: Can't get fortress zones to align to the proper team.

Post by Light »

Check out my "Light's Test Server" and see if that's what you were after.

I used Z-Man's map as a reference, and threw some of your stuff in there. It's up on the server.

Include the map

Code: Select all

RESOURCE_REPOSITORY_SERVER http://lightron.no-ip.org/armagetronad/
MAP_FILE mackay/fortress/forty-1.0.1.aamap.xml
Link to map file: http://lightron.no-ip.org/armagetronad/ ... .aamap.xml

Enjoy.

User avatar
kyle
Reverse Outside Corner Grinder
Posts: 1867
Joined: Thu Jun 08, 2006 3:33 pm
Location: Indiana, USA, Earth, Milky Way Galaxy, Universe, Multiverse
Contact:

Re: Can't get fortress zones to align to the proper team.

Post by kyle »

back to spawn section of the code

Code: Select all

   <Spawn x="304" y="512" xdir="0" ydir="-1"/>
   <Spawn x="304" y="384" xdir="0" ydir="1"/>
   <Spawn x="448" y="368" xdir="-1" ydir="0"/>
   <Spawn x="320" y="368" xdir="1" ydir="0"/>
   <Spawn x="304" y="224" xdir="0" ydir="1"/>
   <Spawn x="304" y="352" xdir="0" ydir="-1"/>
   <Spawn x="160" y="368" xdir="1" ydir="0"/>
   <Spawn x="288" y="368" xdir="-1" ydir="0"/>
   <Spawn y="-503.75" x="493.5" ydir="0.0" xdir="-1"/>
   <Spawn y="-504.25" x="480.0" ydir="0.0" xdir="1"/>
   <Spawn y="-359.75" x="624.75" ydir="-1" xdir="0"/>
   <Spawn y="-359.75" x="348.75" ydir="-1" xdir="0"/>
    
   </Spawn>
Teams will only be spawned on the first 2 points. this is why subspawns are needed wich require a dtd aka the second line should change to

Code: Select all

<!DOCTYPE Resource SYSTEM "ct/map-0.2.8.3.1_sty+ct-r1.dtd">
and those lines need grouped into teams
assuming 6 spawn points taking first 6 for one team and other 6 for the other (nore remove the / before the > on the first one for each, then you use the </spawn> after them all.

Code: Select all

   <Spawn x="304" y="512" xdir="0" ydir="-1">
   <Spawn x="304" y="384" xdir="0" ydir="1"/>
   <Spawn x="448" y="368" xdir="-1" ydir="0"/>
   <Spawn x="320" y="368" xdir="1" ydir="0"/>
   <Spawn x="304" y="224" xdir="0" ydir="1"/>
   <Spawn x="304" y="352" xdir="0" ydir="-1"/>
   </Spawn>

   <Spawn x="160" y="368" xdir="1" ydir="0">
   <Spawn x="288" y="368" xdir="-1" ydir="0"/>
   <Spawn y="-503.75" x="493.5" ydir="0.0" xdir="-1"/>
   <Spawn y="-504.25" x="480.0" ydir="0.0" xdir="1"/>
   <Spawn y="-359.75" x="624.75" ydir="-1" xdir="0"/>
   <Spawn y="-359.75" x="348.75" ydir="-1" xdir="0"/>
    
   </Spawn>
Image

OldMcdonald
On Lightcycle Grid
Posts: 11
Joined: Wed Jun 20, 2012 2:16 am

Re: Can't get fortress zones to align to the proper team.

Post by OldMcdonald »

Thanks guys, I appreciate all the help.
Not really sure if i've got it like I want it yet, but it looks ok thus far.
I'm drained now tho, so I think i'll hit the sack and tackle any other problems that may arise tomorrow when i'm more clear in the head.

Once again, it's really thankful for all your help

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: Can't get fortress zones to align to the proper team.

Post by LOVER$BOY »

OldMcdonald wrote:Thanks guys, I appreciate all the help.
Not really sure if i've got it like I want it yet, but it looks ok thus far.
I'm drained now tho, so I think i'll hit the sack and tackle any other problems that may arise tomorrow when i'm more clear in the head.

Once again, it's really thankful for all your help
No problems dude, sleep well :)
Image

solarcold
On Lightcycle Grid
Posts: 19
Joined: Wed May 15, 2013 6:41 am

Re: Can't get fortress zones to align to the proper team.

Post by solarcold »

[offtopic]
Oh loverboy dude, missed ya as hell!
[/offtopic]

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: Can't get fortress zones to align to the proper team.

Post by LOVER$BOY »

solarcold wrote:[offtopic]
Oh loverboy dude, missed ya as hell!
[/offtopic]
Hey SC :D

This is not the place to talk so come and visit http://vertrex.tk/forum and let's chat :D
Image

Post Reply