0.2.8.3_rc1 available! Post bug reports here.

Help test release candidates for the next release
User avatar
Z-Man
God & Project Admin
Posts: 11233
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by Z-Man »

Well, maybe it doesn't help find the cause, but a workaround: If the lower sky is disabled, do the same as if it was enabled, just draw an invisibly small polygon.

User avatar
Z-Man
God & Project Admin
Posts: 11233
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by Z-Man »

Do things change if you toggle high rim (from preferences, only takes effect on new rounds)?

User avatar
sinewav
Graphic Artist
Posts: 6204
Joined: Wed Jan 23, 2008 3:37 am
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by sinewav »

Z-Man wrote:Do things change if you toggle high rim (from preferences, only takes effect on new rounds)?
You know what? It does. And it doesn't even need a new round for the bug to surface - it's instantaneous.

HIGH_RIM 1 + LOWER_SKY 1 = BUG
HIGH_RIM 0 + LOWER_SKY 1 = OK
HIGH_RIM 1 + LOWER_SKY 0 = OK

I've tried other combinations with upper_sky, sparks, explosions, but it looks like those two do it.

User avatar
Z-Man
God & Project Admin
Posts: 11233
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by Z-Man »

What about the floor mode? Try high rim disabled, lower sky enabled and then disable floor rendering.

User avatar
sinewav
Graphic Artist
Posts: 6204
Joined: Wed Jan 23, 2008 3:37 am
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by sinewav »

Z-Man wrote:What about the floor mode? Try high rim disabled, lower sky enabled and then disable floor rendering.
No bug with the above settings. However, there is a different anomaly when the floor is disabled, independent of other settings. Pic attached.
You do not have the required permissions to view the files attached to this post.

User avatar
Z-Man
God & Project Admin
Posts: 11233
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by Z-Man »

That red line going diagonally, you mean? Is it still there if you switch the floor mode to 'grid only'? I suspect that's closer to the true reason of the glitch, something usually hidden because it is rendered only below the floor and thus invisible.

User avatar
sinewav
Graphic Artist
Posts: 6204
Joined: Wed Jan 23, 2008 3:37 am
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by sinewav »

Z-Man wrote:That red line going diagonally, you mean? Is it still there if you switch the floor mode to 'grid only'?
Yeah it's there with grid only too. In fact , at times it's very pronounced. The attached pic shows it affecting the model texture too.
You do not have the required permissions to view the files attached to this post.

User avatar
Z-Man
God & Project Admin
Posts: 11233
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by Z-Man »

Interesting, it's in front of the floor gridlines, which means it's not something rendered, but hidden, with the regular floor.

Anyway, shuffled some code around, produced this test build. Best case expected result would be that the texture bug is gone in all setting combinations, but only for the regular image. It should still affect the mirror image on the floor. There's rendering artefacts to be expected if you drive around zones in incam mode and look up, so I don't know yet whether I can push the code into bzr.

User avatar
sinewav
Graphic Artist
Posts: 6204
Joined: Wed Jan 23, 2008 3:37 am
Contact:

Re: 0.2.8.3_rc1 available! Post bug reports here.

Post by sinewav »

Oh boy, this IS interesting. Just as you predicted, the main issue with the trail texture disappearing is solved when the floor is rendered, but not with the floor off. Check out the attached image with floor off and full mirror effect on.
You do not have the required permissions to view the files attached to this post.

Post Reply