SDL_PARACHUTE_ERROR solved ;)

For all the help you need with Armagetron!
Post Reply
User avatar
klax
Project Developer
Posts: 481
Joined: Tue Jun 08, 2004 3:51 pm
Location: Barcelona, Spain
Contact:

SDL_PARACHUTE_ERROR solved ;)

Post by klax »

When launching armagetronad in my Fedora Core 2 a lot of times it chashed throwing this error:
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

After months searching I finally solved this error. It was a problem finding the right audio driver. I solved it doing this:
[[email protected] klaxnek]$ export SDL_AUDIODRIVER=alsa
[[email protected] klaxnek]$ armagetronad

Or simply editing /usr/local/bin/armagetronad and adding at the beginning 'export SDL_AUDIODRIVER=alsa'

If you are not using ALSA or you get this error using another OS you can try with these another SDL_AUDIODRIVER:

Code: Select all

openbsd (OpenBSD)
dsp (OSS /dev/dsp: Linux, Solaris, BSD etc)
alsa (Linux)
audio (Unix style /dev/audio: SunOS, Solaris etc)
AL (Irix)
artsc (ARTS audio daemon)
esd (esound audio daemon)
nas (NAS audio daemon)
dma (OSS /dev/dsp, using DMA)
dsound (Win32 DirectX)
waveout	(Win32 WaveOut)
baudio (BeOS)
sndmgr (MacOS SoundManager)
paud (AIX)
AHI (Amiga)
disk (all; output to file)

User avatar
Tank Program
Forum & Project Admin, PhD
Posts: 6709
Joined: Thu Dec 18, 2003 7:03 pm

Post by Tank Program »

Wow! Well done!
Image

User avatar
Marrow
MVP - Project Contributor
Posts: 1655
Joined: Mon Jan 19, 2004 9:05 am
Location: New York

Post by Marrow »

Well done indeed!

User avatar
Zapple
Shutout Match Winner
Posts: 876
Joined: Sun Mar 07, 2004 2:42 am
Location: Halo 2
Contact:

Post by Zapple »

*Applause*

Post Reply