Cannot connect master server // and cannot host dedicated

For all the help you need with Armagetron!
Post Reply
User avatar
Rackover
On Lightcycle Grid
Posts: 10
Joined: Sat Aug 05, 2017 11:36 am
Location: France

Cannot connect master server // and cannot host dedicated

Post by Rackover »

Hi.
I've been playing Armagetronad for years but stopped something like two years ago. I used to play on the Stellar Nebula server and I remember the community being very active.
Now I wanted to host a dedicated game on my linux serv but for an unknown reason, it seems impossible to connect the game from my windows PC (even more terrible : I cannot connect the dedicated game with the client game launched from the linux server...! connecting 127.0.0.1:4534 does not work).
This server is used to host numerous game servers, and also a web server and tons of other stuff. I opened the 4534 port in my router, added a 4534 rule in iptables (there was already one made by armagetronad-dedicated) and disabled the firewall on my windows machien to be sure I could connect.
But still I cannot see the master server nor connect to my own game. Is the master server down (the community seems pretty dead now, there's a lot of dead links everywhere even on the main site) ? Or is something wrong with my configuration ? (My server configuration is default, I changed nothing).
My armagetronad and my armagetronad-dedicated are up to date. What info do you need ?
Is there nothing cosmic left for you ?
You sure ?
Well...

User avatar
Light
Reverse Outside Corner Grinder
Posts: 1664
Joined: Thu Oct 20, 2011 2:11 pm

Re: Cannot connect master server // and cannot host dedicate

Post by Light »

The console log would be a good start, if you could post that. Please use code tags.

User avatar
Rackover
On Lightcycle Grid
Posts: 10
Joined: Sat Aug 05, 2017 11:36 am
Location: France

Re: Cannot connect master server // and cannot host dedicate

Post by Rackover »

Here it is :

Code: Select all

[email protected]:~⟫ sudo cat /var/log/armagetronad-dedicated.log
[0] Command CM_LOCY unknown.
[0]
[0] Bound socket to *.*.*.*:58637.
[0] Bound socket to *.*.*.*:4534.
[0] Ping charity changed from 0 to 500.
[0] Nobody there. Taking a nap...
[0] Timestamp: 2017/08/06 16:23:24
[0] Closing socket bound to *.*.*.*:4534
[0] Bound socket to *.*.*.*:4534.
It stays like this forever, would I try to join or not. I also tried to put a "SERVER_IP 192.168.1.77" in the autoexec.cfg, which produces the same log except *.*.*.* is replaced by 192.168.1.77.


Here is what i've got with TALK_TO_MASTER 1.

Code: Select all

[0] Command CM_LOCY unknown.
[0]
[0] Bound socket to *.*.*.*:4534.
[0] Connecting to Master Server 1...
[0] Killing user 0, ping 1.25.
[0] Login information sent. Waiting for reply...
[0] Got address 77.144.233.158:4534.
[0] Login Succeeded. User Nr. 1
[0] Syncing with server...
[0] Relabeling NetObjects...
[0] Syncing again...
[0] Done!
[0] Sending my server info...
[0] Logging out...
[0] Done!
[0] Killing user 0, ping 0.193527.
[0] Closing socket bound to *.*.*.*:4534
[0] Bound socket to *.*.*.*:4534.
[0] Connecting to Master Server 2...
[0] Killing user 0, ping 1.25.
[0] Login information sent. Waiting for reply...
[0] Login Succeeded. User Nr. 1
[0] Syncing with server...
[0] Relabeling NetObjects...
[0] Syncing again...
[0] Done!
[0] Sending my server info...
[33] Killing user 33, ping 1.25.
[0] Logging out...
[0] Done!
[0] Killing user 0, ping 0.181741.
[0] Closing socket bound to *.*.*.*:4534
[0] Bound socket to *.*.*.*:4534.
[0] Connecting to Master Server 3...
[0] Killing user 0, ping 1.25.
[0] Login information sent. Waiting for reply...
[0] Login Succeeded. User Nr. 1
[0] Syncing with server...
[0] Relabeling NetObjects...
[0] Syncing again...
[0] Done!
[0] Sending my server info...
[33] Killing user 33, ping 1.25.
[0] Logging out...
[0] Done!
[0] Killing user 0, ping 0.182519.
[0] Closing socket bound to *.*.*.*:4534
[0] Bound socket to *.*.*.*:4534.
[0] Connecting to Master Server 4...
[0] Killing user 0, ping 1.25.
[0] Login information sent. Waiting for reply...
[0] Login Succeeded. User Nr. 1
[0] Syncing with server...
[0] Relabeling NetObjects...
[0] Syncing again...
[0] Done!
[0] Sending my server info...
[33] Killing user 33, ping 1.25.
[0] Logging out...
[0] Done!
[0] Killing user 0, ping 0.216152.
[0] Closing socket bound to *.*.*.*:4534
[0] Bound socket to *.*.*.*:4534.
[0] Ping charity changed from 0 to 500.
[0] Nobody there. Taking a nap...
[0] Timestamp: 2017/08/06 20:43:32
[0] Closing socket bound to *.*.*.*:4534
[0] Bound socket to *.*.*.*:4534.
Last edited by Rackover on Sun Aug 06, 2017 7:46 pm, edited 1 time in total.
Is there nothing cosmic left for you ?
You sure ?
Well...

User avatar
Light
Reverse Outside Corner Grinder
Posts: 1664
Joined: Thu Oct 20, 2011 2:11 pm

Re: Cannot connect master server // and cannot host dedicate

Post by Light »

I'm guessing TALK_TO_MASTER isn't set to 1? It doesn't even appear to be attempting.

User avatar
Rackover
On Lightcycle Grid
Posts: 10
Joined: Sat Aug 05, 2017 11:36 am
Location: France

Re: Cannot connect master server // and cannot host dedicate

Post by Rackover »

Well whenever I activate TALK_TO_MASTER, it changes nothing. Anyway the master seems dead.

By the way, I'm getting a VERY annoying "please wait until an administrator valides your post" each time I try and write something here, so that and the fact that you cannot answer immediatly puts a latency of a few hours between every of our posts. I don't get why this even exists, but because of so, I beg you to ask more than one question in your posts. Tell me what to include, do and try to get help and make this work. Give me directions and stuff, this way we can make posts more useful and this whole protection shit less frustrating.
@Administrator, if you see this, why the complication ? What does it take to be "quality-qualified" and get rid of this limitation?
Is there nothing cosmic left for you ?
You sure ?
Well...

User avatar
Light
Reverse Outside Corner Grinder
Posts: 1664
Joined: Thu Oct 20, 2011 2:11 pm

Re: Cannot connect master server // and cannot host dedicate

Post by Light »

Rackover wrote:Well whenever I activate TALK_TO_MASTER, it changes nothing. Anyway the master seems dead.

By the way, I'm getting a VERY annoying "please wait until an administrator valides your post" each time I try and write something here, so that and the fact that you cannot answer immediatly puts a latency of a few hours between every of our posts. I don't get why this even exists, but because of so, I beg you to ask more than one question in your posts. Tell me what to include, do and try to get help and make this work. Give me directions and stuff, this way we can make posts more useful and this whole protection shit less frustrating.
@Administrator, if you see this, why the complication ? What does it take to be "quality-qualified" and get rid of this limitation?
It's done because people like to spam here. Not sure what makes it worth it, being as we're so small, but whatever gets them off .. If you can catch me online, my site is https://lightron.org and I have a live chat there. I'm Kira if you visit. I also have a support forum there if I'm not online when you're around.

Also, with TALK_TO_MASTER, you should see attempts to reach the master in the console log. That's what I was hoping to see. Also, I believe the server uses random outbound ports to talk to the master, so your iptables could potentially be an issue depending on how strict they are. Maybe give the output of "iptables -nL".

User avatar
Lucifer
Project Developer & Local Moonshiner
Posts: 8610
Joined: Sun Aug 15, 2004 3:32 pm
Location: Republic of Texas
Contact:

Re: Cannot connect master server // and cannot host dedicate

Post by Lucifer »

Light wrote: It's done because people like to spam here. Not sure what makes it worth it, being as we're so small, but whatever gets them off .. If you can catch me online, my site is https://lightron.org and I have a live chat there. I'm Kira if you visit. I also have a support forum there if I'm not online when you're around.

Also, with TALK_TO_MASTER, you should see attempts to reach the master in the console log. That's what I was hoping to see. Also, I believe the server uses random outbound ports to talk to the master, so your iptables could potentially be an issue depending on how strict they are. Maybe give the output of "iptables -nL".
One of these days, I'll take a screen shot of the post queue. There's literally like six posts in there from spambots right now and only two legitimate posts.

@Rackover: I'm getting to your posts as quickly as I can. I think I'm the only moderator that's around right now, because of vacations and stuff. I'll try to get to them quicker. If you need help faster, you can always try the irc channel on freenode. But that can take a bit before you get a response, as well. People are just, well, busy, these days.
Image

Be the devil's own, Lucifer's my name.
- Iron Maiden

User avatar
Rackover
On Lightcycle Grid
Posts: 10
Joined: Sat Aug 05, 2017 11:36 am
Location: France

Re: Cannot connect master server // and cannot host dedicate

Post by Rackover »

Hi Lucifer (cool name)
Thanks for answering my question. I'm amazed by the fact that, well, there are this little posts and this much spam posts. That sound incredible! why would even someone spam an almost-inactive forum, and keep recreating accounts to spam it again and again ? Very sad indeed.

I'm using Light's site's chat right now so I can get an answer quickly. Don't worry about validating my post this quickly, I'm not in the same timezone than you and Light and that's the main reason why this is so annoying to me. I wasn't specifically complaining about your speed, more about why do I need validation while you should be about sure right now that I'm definetly not a bot.
Is there nothing cosmic left for you ?
You sure ?
Well...

Monkey
Match Winner
Posts: 744
Joined: Thu May 22, 2008 12:36 am
Location: England, UK

Re: Cannot connect master server // and cannot host dedicate

Post by Monkey »

Spamming here is a real problem so any tools the mods use to reduce it gets my vote.
Playing since December 2006

User avatar
Lucifer
Project Developer & Local Moonshiner
Posts: 8610
Joined: Sun Aug 15, 2004 3:32 pm
Location: Republic of Texas
Contact:

Re: Cannot connect master server // and cannot host dedicate

Post by Lucifer »

Rackover wrote:Hi Lucifer (cool name)
Thanks for answering my question. I'm amazed by the fact that, well, there are this little posts and this much spam posts. That sound incredible! why would even someone spam an almost-inactive forum, and keep recreating accounts to spam it again and again ? Very sad indeed.

I'm using Light's site's chat right now so I can get an answer quickly. Don't worry about validating my post this quickly, I'm not in the same timezone than you and Light and that's the main reason why this is so annoying to me. I wasn't specifically complaining about your speed, more about why do I need validation while you should be about sure right now that I'm definetly not a bot.
You're not a bot. Go create a topic in Really General, and write like six posts of bullcrap. The limit is 10, after that, you don't need moderator approval. So, do that, give me a bunch of posts to approve en masse, and I'll do it. Problem solved.

We initiated the 10 post rule when the forums were busier, and frankly, considering how easy it makes moderating this place, I'd like to keep something like that. I wouldn't object to reducing the count to like five or something like that. But what I get out of it as a moderator is that I get to look at all new posts, see a bunch of spam, go to a screen showing me all of them, hit a "select all" button, then pick out the ones that are clearly genuine posts and deselect them, and press a "disapprove posts" button. Previously, I had to go through each spam post by hand, move it to a topic that's hidden from everybody (it's called "Trash" in case you were wondering), and I had to split topics and all sorts of crap. It was really a pain in the ass. This new system we've got, which isn't that new, is really helpful.

So, upshot, I wouldn't mind reducing the number of posts before you get to post without being moderated, but I'm not willing to give up the system we have, because it's been so helpful.

So, go write those posts, and I'll approve them, and we'll fast-track you past the 10 post rule. Seems reasonable to me.
Image

Be the devil's own, Lucifer's my name.
- Iron Maiden

User avatar
Z-Man
God & Project Admin
Posts: 11426
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Re: Cannot connect master server // and cannot host dedicate

Post by Z-Man »

I approve, 5 posts seems about enough.

The system is there and good for two reasons. Both are invisible to you guys now. The first one are the regular advertising/link farming/SEO spambots. We get about 5 to 10 posts of them per day, they get caught and eliminated. The second reason is invisible even to us mods, its angry teens vandalizing the forums with junk spam torrents. They don't even try now. (And writing that, I bet another sleeper account is going to get activated soonish. Hey, just FYI: My phone now makes a noise on new public posts.)

Rackover: AFAIK, the limit is 15. Mrs. Tubesocks broke free only after that many posts. So you'll need six more posts. I really don't want the junk post method to turn into the canonical way to get to regular status, needless to say.

On topic: My master logs show your server making the connection and making itself known. But neither the master nor a client on my PC can connect to it. Is it a home server behind a router? Seems so. You need to set up port forwarding. If you're on a rented server, you probably just need to set up the firewall to open UDP port 4534, that can usually be done somewhere in the web admin interface.

User avatar
Lucifer
Project Developer & Local Moonshiner
Posts: 8610
Joined: Sun Aug 15, 2004 3:32 pm
Location: Republic of Texas
Contact:

Re: Cannot connect master server // and cannot host dedicate

Post by Lucifer »

Z-Man wrote:So you'll need six more posts. I really don't want the junk post method to turn into the canonical way to get to regular status, needless to say.
I agree, so it's probably worth explaining my reasoning. :) The probationary period is there also to deal with people who show up, and then give us completely useless/potentially hurtful posts, oftentimes not realizing what they're doing. In this one specific situation, here, I saw a guy who really needed help and was doing Everything Right, so I was willing to fast-track him out of probation so he could get help faster. The two important traits here are 1) that he was looking for tech support for his server, and 2) that he was doing so actively and correctly. If he'd just been participating in regular conversation (no tech support need), I'd have just kept approving his posts until he passed the limit.
Image

Be the devil's own, Lucifer's my name.
- Iron Maiden

User avatar
aP|Nelg
Match Winner
Posts: 593
Joined: Wed Oct 22, 2014 10:22 pm
Contact:

Re: Cannot connect master server // and cannot host dedicate

Post by aP|Nelg »

His server is working, although on a very strange port. "Racknet Stellerlike"

Word
Reverse Adjust Outside Corner Grinder
Posts: 4196
Joined: Wed Jan 07, 2009 6:13 pm

Re: Cannot connect master server // and cannot host dedicate

Post by Word »

Racknet Stellerlike
That'd be a good porn actor name.

User avatar
Rackover
On Lightcycle Grid
Posts: 10
Joined: Sat Aug 05, 2017 11:36 am
Location: France

Re: Cannot connect master server // and cannot host dedicate

Post by Rackover »

Yes ! Problem solved by shifting the server to a different port (4080). Thanks to nelG and Kira(Light) for help!
The server is now running under the name "RackNet Stellarlike" as I tried to mimic the configurations of what I remember was Stellar Nebula (also did the same cool gradient on the name).
Thank you for everything!
Is there nothing cosmic left for you ?
You sure ?
Well...

Post Reply