Shrunkland in 2.8

Mmmm... What's cookin in the kitchen?

Moderator: Lucifer

Swampy
Core Dumper
Posts: 165
Joined: Wed Dec 08, 2004 1:33 am
Location: Southern New Jersey

Shrunkland in 2.8

Post by Swampy »

I decided to hold back on the release of Swampland in 2.8, and move on Shrunkland first instead. I think I have the feel pretty close to what it should be, but it will need more tweaking.

I don't know if this is going to be the cure for the t-bones and outer rim issues that I'm trying to address or not, so I'm going to reach out to the guru's for some help. The nose of the bike still seems touchy to me - but it could just be a perception issue on my part.

I've been having problems connecting to the master server the last couple of days - so Shrunkland in 2.8_beta 4 may not be in your list.

(let me know if it is though :wink: )

User avatar
Phytotron
Formerly Oscilloscope
Posts: 5041
Joined: Thu Jun 09, 2005 10:06 pm
Location: A site or situation, especially considered in regard to its surroundings.
Contact:

Post by Phytotron »

I think you've gotten it fairly close. Just as a note, here are the two main things that still remain to be tweaked:

1) The ability to 180 grind a number of times in succession. This surely needs to be reduced, for all the usual reasons. In my opinion, a single 180 grind (maybe two) before exploding would be optimum. I dunno how to alter this.

2) Rubber feels about right at slow speeds, but becomes very touchy at higher speeds (I've previously noticed this in other beta servers as well). One could argue that this is a good punishment for speeders* :twisted: but it probably shouldn't be nearly as touchy as it is, especially if trying to replicate the old Shrunkland. I think we discovered that changing (I can't remember whether you increased or decreased) cycle_rubber_speed fixes this?

Other than those two things, I can't really think of anything off-hand that was really off.

* No, I don't mean the clan specifically.

User avatar
Z-Man
God & Project Admin
Posts: 11426
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Post by Z-Man »

For 2), you want to set CYCLE_RUBBER_TIMEBASED to 1.0. This should give rubber the same feel no matter at what speed you go. Values between 0 and 1 are allowed, too.

For 1), your basic ticket is CYCLE_RUBBER_DELAY. This disables/weakens rubber shortly after turns. If you set CYCLE_RUBBER_DELAY_BONUS to 0, repeated 180ers face immediate death.

User avatar
Jonathan
A Brave Victim
Posts: 3392
Joined: Thu Feb 03, 2005 12:50 am
Location: Not really lurking anymore

Post by Jonathan »

z-man wrote:Values between 0 and 1 are allowed, too.
I think z-man meant !(x>=0 && x<=1).
ˌɑrməˈɡɛˌtrɑn

User avatar
Z-Man
God & Project Admin
Posts: 11426
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Post by Z-Man »

That, too :) But all I actually wanted to say is that it's not just a choice of 0 or 1, and the values in between make most sense.

OT: Hey, I can edit the tip above the edit box :)

User avatar
Lucifer
Project Developer & Local Moonshiner
Posts: 8610
Joined: Sun Aug 15, 2004 3:32 pm
Location: Republic of Texas
Contact:

Post by Lucifer »

Heh, that's pretty silly. Editing the tip above the edit box, that is.

Ontopic: I found through experimentation that setting values between 0 and 1 increased ping times and lag, and also setting that particular value to 1 increased lag just a bit. Noticeable on my dinky server, anyway.
Image

Be the devil's own, Lucifer's my name.
- Iron Maiden

Swampy
Core Dumper
Posts: 165
Joined: Wed Dec 08, 2004 1:33 am
Location: Southern New Jersey

Post by Swampy »

For 1), your basic ticket is CYCLE_RUBBER_DELAY. This disables/weakens rubber shortly after turns. If you set CYCLE_RUBBER_DELAY_BONUS to 0, repeated 180ers face immediate death.
I changed that value to 0 today, but I can still do a ton of 180's. Could there be another setting that I need to change to make it difficult for players to bust out a ton of 180s?

User avatar
Z-Man
God & Project Admin
Posts: 11426
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Post by Z-Man »

You need to modify both values. I assume you set CYCLE_RUBBER_DELAY_BONUS to 0, but left CYCLE_RUBBER_DELAY at 0. Set CYCLE_RUBBER_DELAY to .5 (0.1 may do, experiment a bit).

User avatar
Phytotron
Formerly Oscilloscope
Posts: 5041
Joined: Thu Jun 09, 2005 10:06 pm
Location: A site or situation, especially considered in regard to its surroundings.
Contact:

Post by Phytotron »

So, we've been having what seem to be arbitrary explosions, even when one apparently has plenty of rubber. They usually happen at lower speeds, I think. I've noticed this in other beta servers as well. Don't know what causes it.

Then I had a thought. Now, remember I don't know jack squat, but here's my thought anyway. Swampy's got the anti-180 grinding and anti-adjust things going on, which are good. Is it possible that these seemingly arbitrary explosions are due to a sort of "false positive" where the game reads the player as making an adjust when he really hasn't, and proceeds to core him?

As it stands, it has kind of filled the role of the now-absent t-bones.

User avatar
Lucifer
Project Developer & Local Moonshiner
Posts: 8610
Joined: Sun Aug 15, 2004 3:32 pm
Location: Republic of Texas
Contact:

Post by Lucifer »

I suspect Swampy's sitting there in spectator mode typing /admin kill Oscil

;)
Image

Be the devil's own, Lucifer's my name.
- Iron Maiden

User avatar
Phytotron
Formerly Oscilloscope
Posts: 5041
Joined: Thu Jun 09, 2005 10:06 pm
Location: A site or situation, especially considered in regard to its surroundings.
Contact:

Post by Phytotron »

har

User avatar
Phytotron
Formerly Oscilloscope
Posts: 5041
Joined: Thu Jun 09, 2005 10:06 pm
Location: A site or situation, especially considered in regard to its surroundings.
Contact:

Post by Phytotron »

So, hanger and I are both convinced that the new Shrunkland feels and plays faster than the old Shrunkland. I don't know what it is, why it is, or even if it is, but it sure seems like it is. Are cycle_speed, cycle_start_speed, and cycle_accel exactly what they were in the old Shrunkland? Are we delusional?

User avatar
Lucifer
Project Developer & Local Moonshiner
Posts: 8610
Joined: Sun Aug 15, 2004 3:32 pm
Location: Republic of Texas
Contact:

Post by Lucifer »

I think you guys are delusional. The server is performing better than it used to, but the simulation feels very much right. Except for the 180s, but I'm sure swampy will cure that. ;)
Image

Be the devil's own, Lucifer's my name.
- Iron Maiden

User avatar
Phytotron
Formerly Oscilloscope
Posts: 5041
Joined: Thu Jun 09, 2005 10:06 pm
Location: A site or situation, especially considered in regard to its surroundings.
Contact:

Post by Phytotron »

Well, Swampy thinks it feels faster too and said he's gonna recheck the settings for the old Shrunk. I reckon it'll get sorted out, whether it's actual or delusional. :wink:

Swampy
Core Dumper
Posts: 165
Joined: Wed Dec 08, 2004 1:33 am
Location: Southern New Jersey

Post by Swampy »

:arrow: I checked the speed settings and they're the same.

:arrow: I also copied over the stats from the old server to the new. We should be picking up where we left off before the upgrade.

Post Reply