Map debugging thread

For developmental things relating to the graphics of the game.
Post Reply
User avatar
SuPeRTaRD
Round Winner
Posts: 300
Joined: Fri Nov 05, 2004 11:53 pm
Location: bedlam
Contact:

Map debugging thread

Post by SuPeRTaRD »

Your Map Preview
Errors -- Is your map valid XML?
No errors found.

^thats what nemos site said about my latest map

i think it may be erroring, cuz for a triangle, i gave it 4 lines instead of 3?

anywho.. anyone see any obvious errors in my map script syntax?

hrmmm mebbe i have too many spawn points! i put 16 of them.. heh

gonna try some stuff..

if i fix it, i will tell on this thread what the problem was

i lowered the spawn points to 12 & triplechecked my headers
but nemos site still gave the same error (yet it posts the map picture) ^^^^

here is the current script, i will also include the conceptual drawing so someone can follow the #'s better
-------------------------------------------------------------
<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>
<!DOCTYPE World SYSTEM "map-0.1-exp.dtd">
<World version="0.1">

<Map name="BludFort" version=".1" author="SuPeRTaRD">
<Field>
<Axes number="4"/>

<Spawn x="250" y="410" angle="270" />
<Spawn x="250" y="90" angle="90" />
<Spawn x="90" y="250" angle="0" />
<Spawn x="410" y="250" angle="180" />

<Spawn x="110" y="430" angle="0" />
<Spawn x="430" y="390" angle="270" />
<Spawn x="390" y="70" angle="180" />
<Spawn x="70" y="110" angle="90" />

<Spawn x="250" y="260" angle="90" />
<Spawn x="260" y="250" angle="0" />
<Spawn x="250" y="240" angle="270" />
<Spawn x="240" y="250" angle="180" />

<Wall>
<Point x="60" y="410" />
<Point x="0" y="410" />
<Point x="0" y="450" />
<Point x="50" y="500" />
<Point x="90" y="500" />
<Point x="90" y="440" />
<Point x="240" y="440" />
<Point x="240" y="480" />
<Point x="230" y="480" />
<Point x="230" y="500" />
<Point x="270" y="500" />
<Point x="270" y="480" />
<Point x="260" y="480" />
<Point x="260" y="440" />
<Point x="410" y="440" />
<Point x="410" y="500" />
<Point x="450" y="500" />
<Point x="500" y="450" />
<Point x="500" y="410" />
<Point x="440" y="410" />
<Point x="440" y="260" />
<Point x="480" y="260" />
<Point x="480" y="270" />
<Point x="500" y="270" />
<Point x="500" y="230" />
<Point x="480" y="230" />
<Point x="480" y="240" />
<Point x="440" y="240" />
<Point x="440" y="90" />
<Point x="500" y="90" />
<Point x="500" y="50" />
<Point x="450" y="0" />
<Point x="410" y="0" />
<Point x="410" y="60" />
<Point x="260" y="60" />
<Point x="260" y="20" />
<Point x="270" y="20" />
<Point x="270" y="0" />
<Point x="230" y="0" />
<Point x="230" y="20" />
<Point x="240" y="20" />
<Point x="240" y="60" />
<Point x="90" y="60" />
<Point x="90" y="0" />
<Point x="50" y="0" />
<Point x="0" y="50" />
<Point x="0" y="90" />
<Point x="60" y="90" />
<Point x="60" y="240" />
<Point x="20" y="240" />
<Point x="20" y="230" />
<Point x="0" y="230" />
<Point x="0" y="270" />
<Point x="20" y="270" />
<Point x="20" y="260" />
<Point x="60" y="260" />
<Point x="60" y="410" />
</Wall>

<ObstacleWall>
<Point x="100" y="420"/>
<Point x="240" y="420"/>
<Point x="240" y="280"/>
<Point x="100" y="420"/>
</ObstacleWall>

<ObstacleWall>
<Point x="260" y="420"/>
<Point x="400" y="420"/>
<Point x="260" y="280"/>
<Point x="260" y="420"/>
</ObstacleWall>

<ObstacleWall>
<Point x="420" y="400"/>
<Point x="420" y="260"/>
<Point x="280" y="260"/>
<Point x="420" y="400"/>
</ObstacleWall>

<ObstacleWall>
<Point x="280" y="240"/>
<Point x="420" y="240"/>
<Point x="420" y="100"/>
<Point x="280" y="240"/>
</ObstacleWall>

<ObstacleWall>
<Point x="400" y="80"/>
<Point x="260" y="80"/>
<Point x="260" y="220"/>
<Point x="400" y="80"/>
</ObstacleWall>

<ObstacleWall>
<Point x="240" y="220"/>
<Point x="240" y="80"/>
<Point x="100" y="80"/>
<Point x="240" y="220"/>
</ObstacleWall>

<ObstacleWall>
<Point x="80" y="100"/>
<Point x="80" y="240"/>
<Point x="220" y="240"/>
<Point x="80" y="100"/>
</ObstacleWall>

<ObstacleWall>
<Point x="220" y="260"/>
<Point x="80" y="260"/>
<Point x="80" y="400"/>
<Point x="220" y="260"/>
</ObstacleWall>

<ObstacleWall>
<Point x="220" y="280"/>
<Point x="280" y="220"/>
</ObstacleWall>

<ObstacleWall>
<Point x="220" y="220"/>
<Point x="280" y="280"/>
</ObstacleWall>

<ObstacleWall>
<Point x="60" y="430"/>
<Point x="60" y="440"/>
<Point x="70" y="440"/>
</ObstacleWall>

<ObstacleWall>
<Point x="430" y="440"/>
<Point x="440" y="440"/>
<Point x="440" y="430"/>
</ObstacleWall>

<ObstacleWall>
<Point x="440" y="70"/>
<Point x="440" y="60"/>
<Point x="430" y="60"/>
</ObstacleWall>

<ObstacleWall>
<Point x="70" y="60"/>
<Point x="60" y="60"/>
<Point x="60" y="70"/>
</ObstacleWall>

<ObstacleWall>
<Point x="40" y="460"/>
<Point x="60" y="440"/>
</ObstacleWall>

<ObstacleWall>
<Point x="460" y="460"/>
<Point x="440" y="440"/>
</ObstacleWall>

<ObstacleWall>
<Point x="460" y="40"/>
<Point x="440" y="60"/>
</ObstacleWall>

<ObstacleWall>
<Point x="40" y="40"/>
<Point x="60" y="60"/>
</ObstacleWall>

</Field>
</Map>
</World>
-----------------------------------------------
Attachments
bludfrtg.jpg
Last edited by SuPeRTaRD on Wed Oct 12, 2005 5:05 pm, edited 2 times in total.

User avatar
Z-Man
God & Project Admin
Posts: 11378
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Post by Z-Man »

It's map-0.1-exp.dtd, not -ext :)

User avatar
SuPeRTaRD
Round Winner
Posts: 300
Joined: Fri Nov 05, 2004 11:53 pm
Location: bedlam
Contact:

Post by SuPeRTaRD »

sweet! good eye.. thx dood! :lol:
i changed it up there in this thread ^ just in case..

hrm.. it still gives an "error" no errors found' error at nemos site, but so do other maps.. i just tested that we know work.. so i guess it works?

I stuck the map in /application data/armagetron/resource/
and typed MAP_FILE mapname.xml in the console in 2.8 b2 & it worked fine :) thats another way to test

if anyone else wants to use this thread to debug some other map, that'd be fine, and we could keep all those long entries out of other map threads..
Last edited by SuPeRTaRD on Thu Oct 13, 2005 5:27 am, edited 1 time in total.

User avatar
dlh
Formerly That OS X Guy
Posts: 2035
Joined: Fri Jan 02, 2004 12:05 am
Contact:

Post by dlh »

I disabled the error checking until I fix something. Sorry for not mentioning that.

If you have libxml2 installed you can check if you maps are valid by doing this (make sure the dtd you use in the same folder as the map/where you run the command)--

Code: Select all

xmllint --valid --noout map_file.xml

bg5
On Lightcycle Grid
Posts: 14
Joined: Sat Jul 30, 2005 12:00 pm

cant get map to work

Post by bg5 »

hi, before debuggin i like to activated my map.

we run armagetron server 0.2.8_beta3 on a debian mashine. so we try to make our one map, the xml definition is not the problem. problem is we cant get our maps to work.

for example i have renamed the standart map in test.xml and add the correct name in settings.cfg but this dosnt work. cleints cant connect.

i am not a great linux / unix admin so please explain me what is to do to get a own map to work.

i already tryed to named the file like the resource headder in the xml file like test-1.0.aamap.xml but this donst work to. :(

every time a client trys to connect he get the massage that is something wrong with the map.

:.greets:.bg5

User avatar
dlh
Formerly That OS X Guy
Posts: 2035
Joined: Fri Jan 02, 2004 12:05 am
Contact:

Re: cant get map to work

Post by dlh »

bg5 wrote:hi, before debuggin i like to activated my map.

we run armagetron server 0.2.8_beta3 on a debian mashine. so we try to make our one map, the xml definition is not the problem. problem is we cant get our maps to work.

for example i have renamed the standart map in test.xml and add the correct name in settings.cfg but this dosnt work. cleints cant connect.

i am not a great linux / unix admin so please explain me what is to do to get a own map to work.

i already tryed to named the file like the resource headder in the xml file like test-1.0.aamap.xml but this donst work to. :(

every time a client trys to connect he get the massage that is something wrong with the map.

:.greets:.bg5
You must also upload the map to a web server and set MAP_URI, so that the clients can download the map.

User avatar
SuPeRTaRD
Round Winner
Posts: 300
Joined: Fri Nov 05, 2004 11:53 pm
Location: bedlam
Contact:

Post by SuPeRTaRD »

does the map_uri line still have a 0 or 1 in it after the address is added?

not, right?

can someone with a working map server paste the 2 lines

the path & the map_url

also, if my map is in /resources/tard/
does the map_uri need to be www.blahblah.fakeaddy.com/tard/mapname.xml

?

also,..

there is a new format for maps, but i read most the new docs on wikki & cant figger out what i need to change on my maps to make them compatible with the current map um.. format
ŠüþéRTàRÐ

User avatar
Z-Man
God & Project Admin
Posts: 11378
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Post by Z-Man »

MAP_URI has been removed, you are now supposed to encode the URI in MAP_FILE, like

Code: Select all

MAP_FILE SuPeRTaRD/SuPeR/SuPeRMaP-0.1.aamap.xml(www.superserver.com/resource/SuPeRTaRD/SuPeR/SuPeRMaP-0.1.aamap.xml)
Note that there must not be spaces to the left or right of the parentheses. The full URI to the file needs to be included, you can't leave out /resource (unless, of course, your HTTP server adds it).

Working example, the fake compatible fortress map:

Code: Select all

MAP_FILE Z-Man/fortress/for_old_clients-0.1.0.aamap.xml(http://resource.armagetronad.net/resource/Anonymous/polygon/regular/square-1.0.1.aamap.xml)
About the format: essentially, you just have to replace the top level tags.

Code: Select all

<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>
<!DOCTYPE World SYSTEM "map-0.1-exp.dtd">
<World version="0.1">
<Map name="BludFort" version=".1" author="SuPeRTaRD">
<Field>
Goes to

Code: Select all

<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>
<!DOCTYPE Resource SYSTEM "map-0.2.8_beta3.dtd">
<Resource type="aamap" name="BludFort" version=".1" author="SuPeRTaRD" category="whatever, can be omitted, defaults to unsorted">
<Map version="2">
<World>
<Field>
with corresponding closing tags. Map and World have swapped places and the meta information is now in the new tag Resource.

User avatar
SuPeRTaRD
Round Winner
Posts: 300
Joined: Fri Nov 05, 2004 11:53 pm
Location: bedlam
Contact:

Post by SuPeRTaRD »

thank you :)
ŠüþéRTàRÐ

Post Reply