Unable to install 2.8.3 (wrong libstdc library)

For the help you need with the old versions, 0.2.6.1 and down.
Post Reply
2beers
Posts: 5
Joined: Wed Nov 30, 2005 2:54 pm

Unable to install 2.8.3 (wrong libstdc library)

Post by 2beers »

Hi!

I can't install the binary for version 2.8.3:
"The version of Standard C++ library is wrong
[IV 3.0 für @gnu.org/libstdc++ ]"

I have installed:
libstdc v.3 (libstdc++6-4.4-dev)

Wich i asume is the latest (standard) available lib in my Distribution.
OS: Linux Mint (derivat from Ubuntu)

On this site there is also a link to an "ubuntu" package (i assume it's a .deb & would probably work on most debian based systems?). Unfortunately though the link doesnt work nomore ("File no longer available").

So what Version of the library would i need? Or better - as i assume i have the newer & don't wanna downgrade & therefore probably mess up other programs that are designed for the latest version of libstdc - what possibilities are there to fix this problem?
Any ideas?

User avatar
Z-Man
God & Project Admin
Posts: 11325
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Re: Unable to install 2.8.3 (wrong libstdc library)

Post by Z-Man »

2beers wrote:I can't install the binary for version 2.8.3:
"The version of Standard C++ library is wrong
[IV 3.0 für @gnu.org/libstdc++ ]"
Who or what gives you this error message? What package are you trying to install? I'm royally confused by the gnu stdc++ version scheme. The .packages should be compiled against a libstdc++ that is compatible with the very latest versions, so I don't see where the problem could be coming from.

Regarding native ubuntu packages, our main page is outdated, the .debs there were outdated, too, so no loss :) You can get our latest .debs here: https://sourceforge.net/projects/armage ... a20100130/
Yeah, they're marked as alpha, but I'll turn them into 0.2.8.3.1 soon, so they should be perfectly safe. They are built on the same system as the .packages, though.

If they don't work (they are only built for Kubuntu, they may work elsewhere, but I can't tell), you can always compile from source.

2beers
Posts: 5
Joined: Wed Nov 30, 2005 2:54 pm

Re: Unable to install 2.8.3 (wrong libstdc library)

Post by 2beers »

Who or what gives you this error message?
Standard "package" installer that is used in (k)ubuntu distros.
I also tried the alpha *.deb package u suggested - got the same error though. (on a different PC - running the former version of Linux mint - with all updates though - so i don't think there is much difference, if any to the latest release).
you can always compile from source.
True - and yet, i am afraid when i compile from source, i'll get even more missing librarys. I'll try next week on a testsystem & let u know how it worked out.
they are only built for Kubuntu
Well - the standard libs should be the same in Kubuntu, ubuntu, Xubuntu, from what i understand?
Linux Mint might use some "dev" libs instead. As they actually do with the lib in question.
If u use Kubuntu - what lib is installed on your system by default?

User avatar
Z-Man
God & Project Admin
Posts: 11325
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Re: Unable to install 2.8.3 (wrong libstdc library)

Post by Z-Man »

Hmm, odd. What version of gcc does your distribution use?

Libraries installed on the build machine:

Code: Select all

[email protected]:~/Tron$ ls /usr/lib/libstdc++*
/usr/lib/libstdc++.so.5  /usr/lib/libstdc++.so.5.0.7  /usr/lib/libstdc++.so.6  /usr/lib/libstdc++.so.6.0.9
The .so.5 is the legacy library for even older applications, AA is linked against the .so.6. Can you paste the output of the same command? (possibly with other library paths, the precise location is allowed to vary)

Here's the link to look at if you want to know what you need to install to compile from source: http://wiki.armagetronad.net/index.php? ... evelopment

Ah. Of course, if your system is 64 bit, you need to install a 32 bit compatibility layer. I can only build 32 bit binaries.

User avatar
nelg
Average Program
Posts: 67
Joined: Wed Apr 25, 2012 12:18 am

Re: Unable to install 2.8.3 (wrong libstdc library)

Post by nelg »

/usr/lib/libstdc++.so.5 /usr/lib/libstdc++.so.5.0.7 /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.6.0.13

Im using 64bit and can only install regualor 0.2 armagetron for it to work... rest doesn't work atall expect under wine (Windows Emerator)
<!DOCTYPE UI><UI version=''3.0'' stdsetdef=>''1''
<class>Form1</class>
<widget class=>''Dialog''

User avatar
Z-Man
God & Project Admin
Posts: 11325
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Re: Unable to install 2.8.3 (wrong libstdc library)

Post by Z-Man »

Those instructions were made for 2beers, not as a poll for everyone.

And both the .deb installers and the zeroinstall streams are available for 64 bit native. You shouldn't have any problems with them. The problems with 32 bit versions of 0.3 and 0.4 are likely caused by missing other libraries.

Post Reply