Windows + MP3, for Joda or K

What do you want to see in Armagetron soon? Any new feature ideas? Let's ponder these ground breaking ideas...
Post Reply
User avatar
Z-Man
God & Project Admin
Posts: 11238
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Windows + MP3, for Joda or K

Post by Z-Man »

Lucifer suspected that the Windows build is done without MP3 support; that is correct. I tried activating it by adding MP3_MUSIC to the list of #defines in SDL_Mixer, but got really strange errors, almost too strange to report: Compilation runs fine, but starting the resulting application gives an unspecific "Application could not be initialized" error. Removing the flag, recompiling SDL_Mixer and, strangely, calling makedist.bat (isn't the result of the compilation placed directly into the build folder?), got rid of the error. Only the optimized (release) build seemed to be affected.

Could one of you have a look at it? Preferably, of course, in branches/0.3.0.

k
Random Identifier & Project Developer
Posts: 345
Joined: Wed Feb 25, 2004 12:54 am
Location: Northern California, USA

Post by k »

It might be the SMPEG library. I found another copy of the dll on the internet which was 205KB versus the 12KB dll in Winlibs. The game just crashes silently now instead of throwing the error.

Edit: SDL_Mixer in Winlibs is 1.2.7. Maybe we need to use the version of smpeg included in their VC6 development archives? It's definately different then the current one in winlibs.
http://www.libsdl.org/projects/SDL_mixe ... -1.2.7.zip
http://www.libsdl.org/projects/SDL_mixe ... .7-VC6.zip

Edit2: Can't even debug. Crashes before it hits main().

User avatar
joda.bot
Match Winner
Posts: 421
Joined: Sun Jun 20, 2004 11:00 am
Location: Germany
Contact:

Post by joda.bot »

Yes, I noticed this too... but it now worked for me ... let me check if I compiled with MP3 support

User avatar
joda.bot
Match Winner
Posts: 421
Joined: Sun Jun 20, 2004 11:00 am
Location: Germany
Contact:

Post by joda.bot »

ok, updated project files to load mp3 support dynamically ... results in the following message:
log wrote: Warning in Mix_Music* eMusicTrack::LoadFile(const char*) in ..\..\src\engine\sou
nd\sdl_mixer\eMusicTrackSDLMixer.cpp:172 :
Failed to load track
The aatrack and m3u format is not really my taste ;).
@Lucifer: Relative Path support and m3u (which usually just contains the path to the music files & "# comments") would be cool.

I also noticed that the field to enter a custom "m3u" might be too small for a very long path, anyway we can get scrolling string item ? (or will they only show a substring once the font is too small ?)

Going to test what causes the crash.

User avatar
joda.bot
Match Winner
Posts: 421
Joined: Sun Jun 20, 2004 11:00 am
Location: Germany
Contact:

Post by joda.bot »

OMG ... sorry, seems to be my bad. I guess I somehow messed up or failed to fully commit smpeg.dll.

heh positive thing: MP3 works ;)

I've just commited a inital sound loading error message support.
It displays a detailed error message why a file could not be played by SDL_Mixer. The DLL in SVN was broken. The correct one works with SDL_mixer ...
SDL_mixer now also dynamically loads (unloads?) OGG and MP3 support.

Post Reply