Error while starting armagetronad-dedicated (OS X)

Post here if you need help setting up your server, etc.
Post Reply
D1SK
Posts: 3
Joined: Fri Feb 15, 2013 5:07 pm

Error while starting armagetronad-dedicated (OS X)

Post by D1SK »

Code: Select all

Last login: Fri Feb 15 14:43:13 on console
Jaakko-Mac-mini:~ jaketyyppi$ /Users/jaketyyppi/Desktop/Armagetron\ Advanced\ Dedicated/armagetronad-dedicated ; exit;
Internal Error: Internal error in static tLanguage* tLanguage::FindStrict(const tString&) in /Users/manuel/Desktop/Tron/Builds/armagetronad-0.2.8.3.2/MacOS/../src/tools/tLocale.cpp:150 : 
 	Language British English not found.
Please send a Bug report!
logout

[Process completed]

Edit:
The file I downloaded from the internet was called "armagetronad-dedicated-0.2.8.3.2.macosx-universal.dmg".

Computer information:
Mac Mini mid-2011
Mac OS X 10.7.5
2.3 GHz Intel Core i5
8 Gt 1333 MHz DDR3

User avatar
delinquent
Match Winner
Posts: 660
Joined: Sat Jul 07, 2012 3:07 am

Re: Error while starting armagetronad-dedicated (OS X)

Post by delinquent »

If you can get into the program files as you can with Windows (I'm not too familiar with mac) you can put the language file into the correct directory manually. The file can be downloaded here.

If that doesn't work, I'm useless.

D1SK
Posts: 3
Joined: Fri Feb 15, 2013 5:07 pm

Re: Error while starting armagetronad-dedicated (OS X)

Post by D1SK »

delinquent wrote:If you can get into the program files as you can with Windows (I'm not too familiar with mac) you can put the language file into the correct directory manually. The file can be downloaded here.

If that doesn't work, I'm useless.
I replaced all the files in my "language" folder with the ones behind your link, got the same exact error :(

User avatar
Z-Man
God & Project Admin
Posts: 11256
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: Error while starting armagetronad-dedicated (OS X)

Post by Z-Man »

It's a little awkward. You have to follow the Wiki instructions:
http://wiki.armagetronad.org/index.php/ ... g_manually
Essentially, running the app bundle directly is not supposed to work. You have to CD into it and run the server from there. I'd fix it if I knew how.

D1SK
Posts: 3
Joined: Fri Feb 15, 2013 5:07 pm

Re: Error while starting armagetronad-dedicated (OS X)

Post by D1SK »

Z-Man wrote:It's a little awkward. You have to follow the Wiki instructions:
http://wiki.armagetronad.org/index.php/ ... g_manually
Essentially, running the app bundle directly is not supposed to work. You have to CD into it and run the server from there. I'd fix it if I knew how.
I did what the wiki told me to do, and the log file was filled with:

Code: Select all

Internal Error: Internal error in static tLanguage* tLanguage::FindStrict(const tString&) in /Users/manuel/Desktop/Tron/Builds/armagetronad-0.2.8.3.2/MacOS/../src/tools/tLocale.cpp:150 : 
 	Language British English not found.
Please send a Bug report!
:P

User avatar
Z-Man
God & Project Admin
Posts: 11256
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne, Jabber: [email protected]
Contact:

Re: Error while starting armagetronad-dedicated (OS X)

Post by Z-Man »

Bottom of the page, "Running manually." There should be no log file generated there.

The rest of the page may be broken, I can't tell and would not be able to correct any errors, I'm completely unfamiliar with the tech involved.

Post Reply