Having trouble configuring VPS

General Stuff about Armagetron, That doesn't belong anywhere else...
Post Reply
User avatar
Agility
Core Dumper
Posts: 131
Joined: Fri Jun 19, 2009 10:22 pm

Having trouble configuring VPS

Post by Agility »

In the past I used this link to setup my server

http://wiki.armagetronad.org/index.php? ... x_computer

However, once I get to this step things go bad...

sudo apt-get install bzr build-essential automake libboost-dev libxml2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev ftgl-dev libglew-dev bison pkg-config autoconf autotools-dev libprotobuf-dev protobuf-compiler

Error message comes up and everything does not download.

I was running ubuntu 18.04 but I reimaged my vps to run debian 10 thinking that would solve the case. Not sure what to do.

User avatar
kyle
Reverse Outside Corner Grinder
Posts: 1863
Joined: Thu Jun 08, 2006 3:33 pm
Location: Indiana, USA, Earth, Milky Way Galaxy, Universe, Multiverse
Contact:

Re: Having trouble configuring VPS

Post by kyle »

What's the error message? It is likely one of those packages is either not in apt-get or the package name has changed.
Image

User avatar
Agility
Core Dumper
Posts: 131
Joined: Fri Jun 19, 2009 10:22 pm

Re: Having trouble configuring VPS

Post by Agility »

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ftgl-dev
[email protected]:/home#

And I know running from root is dangerous but I forget how to setup a user with all privileges lol

User avatar
aP|Nelg
Match Winner
Posts: 587
Joined: Wed Oct 22, 2014 10:22 pm
Contact:

Re: Having trouble configuring VPS

Post by aP|Nelg »

FTGL I believe is only a requirement for the client. Either way, try adding `--ignore-missing` before `install` to the apt command to ignore nonexistent packages.

User avatar
Light
Reverse Outside Corner Grinder
Posts: 1659
Joined: Thu Oct 20, 2011 2:11 pm

Re: Having trouble configuring VPS

Post by Light »

If you want to include it, I believe the package name is now libftgl-dev

User avatar
Agility
Core Dumper
Posts: 131
Joined: Fri Jun 19, 2009 10:22 pm

Re: Having trouble configuring VPS

Post by Agility »

All fixed now, thank you guys for all your help!

Post Reply