[C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Everything todo with programming goes HERE.
User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

[C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

Hello everyone.

I'm having trouble compiling in windows using Code:Blocks 10.05. I tried "Build Workspace" on the Armagetron.workspace. I already did "makedist.bat" to load the "debug" and "dist" folders.

I've uploaded the build log, build messages and the error screen.

Please help.
Attachments
error_page.png
build_messages.txt
(7.22 KiB) Downloaded 89 times
build_log.txt
(22.13 KiB) Downloaded 91 times
Image

User avatar
AI-team
Shutout Match Winner
Posts: 1021
Joined: Tue Jun 23, 2009 6:17 pm
Location: Germany/Munich
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by AI-team »

Building sty+ct on windows is a rather complicated undertaking.
infamous has been compiling the latest sty+ct on windows for years, so you might want to wait until he replies to this thread
  
 
"95% of people believe in every quote you post on the internet" ~ Abraham Lincoln
 
 

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

Rito. I hope he'll reply soon :)
Image

User avatar
kyle
Reverse Outside Corner Grinder
Posts: 1860
Joined: Thu Jun 08, 2006 3:33 pm
Location: Indiana, USA, Earth, Milky Way Galaxy, Universe, Multiverse
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by kyle »

looks like it just failed to build the client If i'm reading that log correctly.
Image

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

ya but what about that error screen?

What am i supposed to do to it? :P

I mean... it stopped at SDL...

also, when I run armagetron_dedicated.exe, i keep getting a pop-up window saying "The program can't start because libgcc_s_dm2-1.dll is missing from your computer. Try reinstalling the program to fix this."

What the heck?
Image

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

does anyone know where I can find these files?:

libsdl.a, libSDL_image.a, libSDL_mixer.a because I keep getting this error when trying to compile "Armagetron" client:

-------------- Build: Win32 Release in Armagetron ---------------

Linking executable: ..\dist\armagetronad.exe
mingw32-g++.exe: error: ..\dist\libSDL.a: No such file or directory
mingw32-g++.exe: error: ..\dist\libSDL_image.a: No such file or directory
mingw32-g++.exe: error: ..\dist\libSDL_mixer.a: No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

I did makedist.bat but it did not make these files. They did not appear even after compiling.

Any ideas please?
Image

User avatar
Tank Program
Forum & Project Admin, PhD
Posts: 6709
Joined: Thu Dec 18, 2003 7:03 pm

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by Tank Program »

LOVER$BOY wrote:"The program can't start because libgcc_s_dm2-1.dll is missing from your computer. Try reinstalling the program to fix this."
This DLL will be somewhere in the Code::Blocks program folder, I think. The fact that it's asking for this though to me says that the compile options aren't set up right.
LOVER$BOY wrote:libsdl.a, libSDL_image.a, libSDL_mixer.a
These are the development equivalents to a dll... their proper name escapes me. If you look in the archive you unpacked the libraries from you may find them there.
Image

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

Tank Program wrote:
LOVER$BOY wrote:"The program can't start because libgcc_s_dm2-1.dll is missing from your computer. Try reinstalling the program to fix this."
This DLL will be somewhere in the Code::Blocks program folder, I think. The fact that it's asking for this though to me says that the compile options aren't set up right.
Actually I misspelled it. It's supposed to be libgcc_s_dw2-1.dll. No Tank. I couldn't find that file within the CodeBlocks. I had to download it manually and insert it to the location of the dist and debug. However, I was under the impression that this wasn't supposed to happen.

I have no idea how to setup these compiling things. I checked the paths and so far they are all set to their respective places.
Tank Program wrote:
LOVER$BOY wrote:libsdl.a, libSDL_image.a, libSDL_mixer.a
These are the development equivalents to a dll... their proper name escapes me. If you look in the archive you unpacked the libraries from you may find them there.
I don't quite understand what you mean Tank.
Image

User avatar
Jonathan
A Brave Victim
Posts: 3392
Joined: Thu Feb 03, 2005 12:50 am
Location: Not really lurking anymore

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by Jonathan »

Tank Program wrote:
LOVER$BOY wrote:libsdl.a, libSDL_image.a, libSDL_mixer.a
These are the development equivalents to a dll... their proper name escapes me. If you look in the archive you unpacked the libraries from you may find them there.
They're called static(ally-linked) libraries. Can't help beyond that, though.
ˌɑrməˈɡɛˌtrɑn

User avatar
Z-Man
God & Project Admin
Posts: 11365
Joined: Sun Jan 23, 2005 6:01 pm
Location: Cologne
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by Z-Man »

The problem with the libraries is that 0.2.8 and sty are not prepared to be compiled with code::blocks 10.05. They're for 1.0_rc2. IIRC, it's easy to solve, though: build the whole workspace and look for files called libsdl.dll.a etc, just remove the .dll part.

Can't help with the missing linker symbols, I don't get those.

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

oh well.

Thanks anyway Z-Man :)

I'll try that out.
Image

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

Ah Z-Man, I tried to build the whole workspace but I got an error when it was compiling the dedicated (I was trying to compile sty+ct)

I've attached it.
Attachments
build_log.txt
(7.38 KiB) Downloaded 158 times
Image

User avatar
kyle
Reverse Outside Corner Grinder
Posts: 1860
Joined: Thu Jun 08, 2006 3:33 pm
Location: Indiana, USA, Earth, Milky Way Galaxy, Universe, Multiverse
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by kyle »

that must be because the makefile or w/e code::Blocks uses does not include the gSvgOutput.c/h in it, a small hack that results in server lagging when activated in sty+ct only, but does produce a nice image of what it going on in the server.
Image

User avatar
LOVER$BOY
Match Winner
Posts: 725
Joined: Thu Jan 24, 2008 12:46 pm
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by LOVER$BOY »

So... what can I do to fix this kyle?
Image

User avatar
kyle
Reverse Outside Corner Grinder
Posts: 1860
Joined: Thu Jun 08, 2006 3:33 pm
Location: Indiana, USA, Earth, Milky Way Galaxy, Universe, Multiverse
Contact:

Re: [C++] 0.2.8+sty+ct Compiling with Code:Blocks troubles

Post by kyle »

I don't know code::blocks, but someplace i would assume you need to tell it that gCycle.cpp, gExplosion.cpp gGame.cpp and gWinZone.cpp are all dependent on gSvgOutput.cpp
Image

Post Reply