Search found 86 matches

by Tannermon11
Thu Jul 21, 2016 4:14 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Figured it out. Apparently it was windows firewall that was preventing the vm from connecting to my computer.
by Tannermon11
Thu Jul 21, 2016 3:19 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Using the virtual network editor I put in the host port (4534) type udp along with the ip address of the VM into the port forwarding of the NAT settings for VMnet8. I have this in vmnetnat.conf in [incomingudp] which (should) take a connection that connects to my computer on port 4534 and then forwa...
by Tannermon11
Thu Jul 21, 2016 3:12 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Hey light check my edit, I don't think it was included in your quote
by Tannermon11
Thu Jul 21, 2016 2:59 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

I had a friend try to connect to it but he was not able to. Talk_to_master is set to 1, but it doesn't seem like it is getting sent out. I've only seen the terminal show my ip on it, but never had any other ip show up on it and had it running for at least 30 minutes. So I just did a test, I ran the ...
by Tannermon11
Wed Jul 20, 2016 11:14 pm
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

So this is what I tried to do with NAT. I am port forwarding the host's ip and then I went into vmnetnat.conf (for VMware) on the host and under [incomingudp] I put in the ip of the host along with the ports for armagetron (4534 etc) I then restarted the network adapter VMnet8. I saw my external ip ...
by Tannermon11
Wed Jul 20, 2016 4:01 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

So I've never done this in a virtual machine before(VMware) and was wondering how you would port forward it through to a virtual machine. I tried searching google but didn't have any luck. I tried using the bridge mode but then the virtual machine lost an internet connection and no matter what I tri...
by Tannermon11
Tue Jul 19, 2016 2:47 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

LOL I just found ladderlog_enabled set to 0
shit it's posting all the ladderlog ingame
When I changed it to 1, it created a ladderlog.txt file and started outputting to it however it was also outputting in game
LOL nvm forget what I said I forgot what script was currently running >.<
by Tannermon11
Tue Jul 19, 2016 2:39 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Got all those settings already in settings_custom.cfg
x.x
by Tannermon11
Tue Jul 19, 2016 2:32 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

http://i.imgur.com/Zgx1Ani.png I looked at the enclosed file alsoand the setting for others is set to read-only and for folders access files only. I try to change it in there but it keeps resetting it. Not sure if that matters since I don't know if it's being executed by 'others' There's only one a...
by Tannermon11
Tue Jul 19, 2016 2:27 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

There is no ladderlog.txt at all in the directory ._.
by Tannermon11
Tue Jul 19, 2016 2:11 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Same thing happens as before. It just does the killing script, then launching external command, but then nothing else happens :/ No idea what is making it get stuck at the fgets stdin either, never heard of that happening. :( The only difference between when it was working on the previous server and...
by Tannermon11
Tue Jul 19, 2016 1:56 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Nothing prints out, copied that into my script.php and nothing happens
by Tannermon11
Mon Jul 18, 2016 10:45 pm
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

So does anyone know why/how $line = rtrim(fgets(STDIN, 1024)); is making nothing work after it? Or how to find out what is going on with this it seems to be the fgets(STDIN,1024) as I put just this into a variable and nothing worked after it...

Is it something with my version of php?
by Tannermon11
Mon Jul 18, 2016 4:41 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

Ok So I put some print statements in the while section as well as the if preg_match part to see if it was getting to those but only one printed out. The print statement in the while loop printed out but the part after the if preg_match invalid_command is not printing. This would mean the invalid com...
by Tannermon11
Sun Jul 17, 2016 6:11 am
Forum: Server Administration/Setup
Topic: Sty+ct+ap server
Replies: 46
Views: 3516

Re: Sty+ct+ap server

So this is an example script I found and I put it in my file called script.php and proceeded to launch the server with ./armagetronad-dedicated --userdatadir '/home/tanner/0.2.9-armagetronad-sty+ct+ap' script.php location is: /home/tanner/0.2.9-armagetronad-sty+ct+ap/scripts calling spawn_script scr...