Search found 117 matches

by Galaxip
Fri Sep 03, 2021 4:38 pm
Forum: The Main Site
Topic: [fixed] @forums armagetron login fails
Replies: 3
Views: 1469

[fixed]

sorry @forums is fine turns out that my broadband (sky) dns servers are totally screwy @forums , any website ending with .tk and many otheres dont connect ive changed my raspberry pi server dns to google and my laptop dns to google and both are working fine today i changed my laptop back to the defa...
by Galaxip
Wed Sep 01, 2021 9:47 pm
Forum: The Main Site
Topic: [fixed] @forums armagetron login fails
Replies: 3
Views: 1469

[fixed] @forums armagetron login fails

its not working, armagetron says its an invalid URL
by Galaxip
Sat Apr 10, 2021 4:44 pm
Forum: Programming
Topic: Writing an old game for an old computer
Replies: 2
Views: 2419

Re: Writing an old game for an old computer

had a go at drawing and redrawing some enmy bugs, 1 set done and 7 more to go
https://www.youtube.com/watch?v=9oGO_GzVFj8
by Galaxip
Fri Apr 09, 2021 12:58 am
Forum: Programming
Topic: Writing an old game for an old computer
Replies: 2
Views: 2419

Writing an old game for an old computer

Im in the process of writing a clone of universals 1981 arcade game ladybug for the acorn bbc microcomputer the original arcade game had a Z80 cpu running at 4MHz with 24K of game program in eprom fast hardware sprites with an extra 16K of eprom dedicated to sprites and game graphics the bbc compute...
by Galaxip
Fri Feb 12, 2021 10:17 pm
Forum: Development
Topic: working on server AI's have an issue
Replies: 8
Views: 1787

Re: working on server AI's have an issue

yeah i thought i would have to free the memory allocated for the original aiplayers.cfg

I still have no clue how to make a command call my custom function :(
by Galaxip
Thu Feb 11, 2021 5:40 pm
Forum: Development
Topic: working on server AI's have an issue
Replies: 8
Views: 1787

Re: working on server AI's have an issue

one thing I would like to do is add a command AI_FILE somefilename to reload the ai settings while im testing but using the filename I specify I see in src/tron/gArmagetron.cpp at line 696 gAICharacter::LoadAll(tString( "aiplayers.cfg" ) ); if I used this line but with a string variable co...
by Galaxip
Thu Feb 11, 2021 2:43 am
Forum: Really General
Topic: https://urbit.org/
Replies: 4
Views: 2142

Re: https://urbit.org/

I only heard about this because someone told me to "check it out, its amazing" but to me it does seem like gibberish

I thought I was missing something but I guess not.

It's good to get other opinions, Thanks
by Galaxip
Wed Feb 10, 2021 9:36 pm
Forum: Development
Topic: working on server AI's have an issue
Replies: 8
Views: 1787

Re: working on server AI's have an issue

I couldnt do the math to calculate the direction and distance between the ai and a cycle and its just a mess of false detections headhunter was kind enough to do a quick demo in javascript which calculates distance and direction correctly and I will base my code on this i've uploaded the page here h...
by Galaxip
Tue Feb 09, 2021 11:30 pm
Forum: Development
Topic: working on server AI's have an issue
Replies: 8
Views: 1787

Re: working on server AI's have an issue

that if(target) fixed the crashing issue but I now I realise im also getting target coordinates from the ai cycle too so any test I was going to do will fail as it'll be tested against itself :( -------------- edit ------------- actually it might work as the difference between the ai and itself will...
by Galaxip
Tue Feb 09, 2021 11:21 pm
Forum: Development
Topic: working on server AI's have an issue
Replies: 8
Views: 1787

Re: working on server AI's have an issue

thanks nelg the missing if(target) was the problem, lbm is defined early on in the code sorry I didnt include it

is there a better what to loop through just the list of cycles instead of all objects ?
by Galaxip
Tue Feb 09, 2021 10:25 pm
Forum: Development
Topic: working on server AI's have an issue
Replies: 8
Views: 1787

working on server AI's have an issue

Hi, i've been making some tweaks to the AI's and everything is going well but I have an issue trying to get x y xdir ydir info from the cycles I added this code into gAIPlayer::Timestep in src/tron/gAIBase.cpp currently it doesnt do anything except read x y xdir and ydir but it just seems to lockup ...
by Galaxip
Tue Feb 02, 2021 4:50 am
Forum: General
Topic: Hello!
Replies: 23
Views: 5635

Re: Hello!

hi MusicMeg21
by Galaxip
Mon Feb 01, 2021 10:44 pm
Forum: Really General
Topic: https://urbit.org/
Replies: 4
Views: 2142

https://urbit.org/

hmmmmmmmm
by Galaxip
Sun Jan 31, 2021 7:24 pm
Forum: Really General
Topic: html css help with repeating image please
Replies: 6
Views: 2347

Re: html css help with repeating image please

thanks ever so much for that code, much nicer working perfectly

this is exactly what I was trying to do for 4 days but never got it to work

I think I hate css scripting even more than bash scripting now